Elevated API Latency on iOS Signups
Incident Report for Jenji
Postmortem

May 25th, 9:54am - our monitoring showed elevated latency on the iOS signup API calls, in p95 and p99 latencies. Users clicking the Signup (not Login) button on iOS have a longer wait time than normal.

May 25th, 10:02am - we identified the root cause, hitting the AWS service limit on concurrent lambda execution in this specific AWS account, making some of those calls timeout or take up to 10-15 seconds.

May 25th, 10:18am - a fix has been pushed to production, the iOS signups are back to normal.

Posted Jun 13, 2022 - 16:20 UTC

Resolved
We're experiencing an elevated level of API latency affecting iOS signups and are currently looking into the issue.
Posted May 25, 2022 - 07:30 UTC